Friday , July 30 2021

Ubisoft reveals list of PS4 games that are not compatible with previous PS5 versions




ass creed

IMPROVEMENT: Ubisoft clarified that there were certain errors with the list of titles compatible with previous versions on PS5 and, by the following statement, they confirmed that the original article has already been removed:

“We removed the Ubisoft Connect article and the forum post on backward compatibility, as there were bugs in some titles compatible with previous Ubisoft versions on PS5.”

——————

Original note: Again, the issue of backward compatibility between current Sony and the next generation is confusing. Although PlayStation mentioned that almost 99% of PS4 games, leaving only a short list out, will be able to work on PS5, Ubisoft has unveiled its own catalog of titles that will not be compatible with the company’s next console.

In a new post on the Ubisoft page, which talks about backward compatibility and cross-progression, it was revealed that Assassin’s Creed Syndicate and more titles will not be supported on PlayStation 5. Here is the complete list:

-Assassin’s Creed Syndicate.

Assassin’s Creed Chronicles trilogy pack.

-Assassin’s Creed Chronicles India.

-Assassin’s Creed Chronicles China.

-Assassin’s Creed Chronicles Russia.

-Risk.

– Star Trek bridge crew.

-Werewolves Within.

-Space Junkies.

However, this only applies to the PS5, as the company made it clear that All Ubisoft Xbox One games will be compatible with the Xbox Series X | S. At the moment, the reason behind this decision is unknown. Remember that in the past Sony mentioned that some PS4 games could have problems running on the following hardware, so it is possible that the titles mentioned above suffer from some inconvenience.

On related topics, Far Cry 6 has been postponed until the next fiscal year. Equally, Immortal Fenyx Rising its development has been completed.

Pleca-Amazon-OK

Via: Ubisoft




Sebastian Quiroz

23 years. Editor at Atomix.vg. Pop culture consumer.




Source link